Linux Ask!

Linux Ask! is a Q & A web site specific for Linux related questions. Questions are collected, answered and audited by experienced Linux users.

Apr 102010

SSH takes a long time to connect or log in


If you experienced slow SSH connect to a remote server, you can try to disable the reverse DNS lookup at the server.

1. Edit the sshd_config

# sudo vi /etc/ssh/sshd_config

2. Add the following line in sshd_config

UseDNS no

3. Restart sshd

# sudo /etc/init.d/ssh restart

 Leave a Reply



You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>